Critical RCE Flaws in ‘PHP Everywhere’ Plugin Affect Thousands of WordPress Sites

Critical security vulnerabilities have been disclosed in a WordPress plugin known as PHP Everywhere that’s used by more than 30,000 websites worldwide and could be abused by an attacker to execute arbitrary code on affected systems.

PHP Everywhere is used to flip the switch on PHP code across WordPress installations, enabling users to insert and execute PHP-based code in the content management system’s Pages, Posts, and Sidebar.

The three issues, all rated 9.9 out of a maximum of 10 on the CVSS rating system, impact versions 2.0.3 and below, and are as follows –

  • CVE-2022-24663 – Remote Code Execution by Subscriber+ users via shortcode
  • CVE-2022-24664 – Remote Code Execution by Contributor+ users via metabox, and
  • CVE-2022-24665 – Remote Code Execution by Contributor+ users via gutenberg block

Successful exploitation of the three vulnerabilities could result in the execution of malicious PHP code that could be leveraged to achieve a complete site takeover.

WordPress security company Wordfence said it disclosed the shortcomings to the plugin’s author, Alexander Fuchs, on January 4, following which updates were issued on January 12, 2022 with version 3.0.0 by removing the vulnerable code entirely. Read more:

Leave a Reply

Your email address will not be published. Required fields are marked *